Minimum PHP recommendation for WordPress is 7.2

#PHP recommendation for WordPress #WordPress

WordPress bumped the lowest branch of PHP which is receiving security updates to 7.2 and the lowest branch of PHP which is actively supported to 7.3.

WordPress announced the ServeHappy API is updated to set the new minimum PHP recommendation for WordPress. According to the announcement, the lowest branch of PHP which is receiving security updates is now 7.2 and the lowest branch of PHP which is actively supported is 7.3. Websites using the older version will now receive an alert from the ServeHappy dashboard widget that urges them to update. According to WordPress stats, 24.3% of WordPress websites using PHP 7.2, 24.7% are using PHP 7.3 and only 4% are using PHP 7.4. Approximately 47% of the websites are using older versions of PHP.

READ ALSO HERE :  Top Free Windows Open Source Web Hosting Control Panels

47% using older versions

Adoption of the latest PHP versions will also boost the security for the website owners and for users. Marius Jensen offered the change by a ticket on WordPress.org. Jensen stated,

“Currently, the ServeHappy dashboard widget is showing the upgrade notice to uses of PHP 5.6 or lower.

After discussing with the core Site Health team, and the Hosting Team, it has come up that the most sensible next move is to show the upgrade notice to users of PHP <=7.1 (this means setting ACCEPTABLE_PHP to 7.2)

Looking at the numbers, we’re seeing roughly 25% of sites running a WordPress version that includes ServeHappy would then get an upgrade notice.

Along with this, the attached patch also updates other relevant versions numbers for the SUPPORTED_PHP and SECURE_PHP versions which relate to the actively supported, and security updates only versions respectively.”

Sergey Biryukov from the WordPress team responded to the ticket and made the change and the official announcement.

READ ALSO HERE :  DigitalOcean customers’ data exposed